XBEE AT Commands via ArduSimple Board

Q&A forumXBEE AT Commands via ArduSimple Board
unic0rned asked 3 months ago

There are many topics alike here.
But has anyone suceeded in talking via AT through the POWER/XBEE USB port
I have tried every setup you can imagine. I have 2 Bluetooth XBEES here. One is HC-05 one is WAVESHARE Dual Mode Bluetooth. Nothings works. No Response from the serial connection. I have tried it on MAC and WINDOWS. Installed the drivers and used 3 different programs. Nothing. I never get a response from AT command.
I am wondering if anyone has used the FTDI USB inside the ArduSimple so far to connect via AT with the XBEES.
One of my XBEE the HC-05 is too slow. Baud Rate is 9600 so I can put rate to maximum of 1500 ms before it overflows.
 
The Waveshare version has a different problem. The baud rate is set to 10 times the other one. But it sometimtes slips on the sending. Somehow the F9P cant read the signal or something. It only happens with the Lefebure Client. Not with ucenter. Than it hangs and no date is received.
I can only recommend buying the preconfigured bluetooth from ardusimple ūüėÄ Its a hell of a thing to setup this stuff.
 
Anyone has an idea how I can get the AT commands to work? 

11 Answers
skypuppy answered 3 months ago

I’ve never had anything from Waveshare work properly, and almost never got any response from their tech “support.”¬† What I did get was worthless.

Kaupoi answered 3 months ago

UBS to TTL (CP2102) dongle and xbee adapter plate is my choice to configure BT Xbee’s. Nothing else really hasn’t worked for me.
https://1drv.ms/u/s!Ao6_PnVNR5RXg_BJCZS0v0eMyDwQYQ 

Ardusimple Staff answered 3 months ago

Hi unic0rned
To enter AT command mode with the HC-05 you need to pull the Key pin to high.
Check on google images to find out the exact pin.
After doing that, you can use your terminal application to connect to the module.
Best regards,
ArduSimple Team

skypuppy answered 2 months ago

Unicorned, have you tried XCTU?¬† I can talk to the xbee units using Linux and Windows with the XCTU software.¬† I can confirm my two 900 mhz units can talk to each other with the XCTU built-in tests but still can’t get them to talk to each other with the gps data.¬† <sigh>

skypuppy answered 2 months ago

Forgot, I had to take the XBEE’s out of AT mode in order to get their built-in comm tests to run.¬† I don’t know if they default to AT mode upon power up or not.