U-Center Question

Q&A forumU-Center Question
Alphabeta asked 3 weeks ago

Hi
I have a SimpleRTK2B board with xbee bluetooth adapter to connect to phone. my question is when i change UBX-CFG-Rate to anything above 2HZ, I see less satelites and overall less accurate. I saw in the new 1.13 configs suggest to disable Beidou to get 10hz without troubles, is this the solution?
I also tried to change the baudrate of the bluetooth, dont think it worked correctly, I still only get results using 38400.
 
Thanks
AL

Ardusimple Staff replied 3 weeks ago

Hi Alphabeta,
It is not possible to increase to 2Hz with the default configuration, the bluetooth doesn’t have enough bandwidth to send everything.
If you go to UBX-CFG-MSG you can disable on UART2 all messages that you don’t need, so you can try to push the datarate higher.

Alphabeta replied 3 weeks ago

Hi
I have UART2 messages that I dont need disabled and I can get 2hz, if I increase the baudrate of the bluetooth, will it improve? If not, is there any alternative method of using the bluetooth to achieve 5hz?

Thanks for the quick reply
AL

Ardusimple Staff replied 3 weeks ago

it might slightly improve with higher baudrate, but the bluetooth bandwidth limit is independen of the baudrate, and will depend on the distance to other device also.

If you disable all messages except GGA it will work without problem at 5Hz. GSV is the main source of problems, as it is a very long message.

Alphabeta replied 3 weeks ago

Ah, I see. I will try it but I think I require GGA messages

Thanks for your help

Ardusimple Staff replied 3 weeks ago

Hi Alphabeta, I think you misunderstood my text. I suggested that you keep GGA, and remove the rest.

Alphabeta replied 3 weeks ago

You’re right, I did misread. Thanks