starter kit LR — no xbee led flash an RTK connections

Q&A forumCategory: Questionsstarter kit LR — no xbee led flash an RTK connections
werner rosendaal asked 8 months ago

Dear ardussimple 
i having a trouble whit my starter lr kit.
when i connect the base en the rover. i will have by the base a time connection en by the rover a 3D connection.
the xbee led will not flash on both devices 
and how i can see when i have a rtk signal?
what i am doing wrong?

Ardusimple Staff replied 8 months ago

Dear Werner,

1. Did you change default configuration?
2. Is the base in TIME mode? you can check this by enabling ubx-nav-pvt. If yes, continue to 3.
3. Does the rover receive corrections? check ubx-mon-msgpp and check if uart2 is receiving bytes.

7 Answers
werner rosendaal answered 8 months ago

hello,
i have now on both devises download the new base en rover config file.
both devises  has now 3D connection
on the base unit. 
led on = no rtk
led flash = gps fix
led weak flash = gps>xbee
 
on the rover unit
led on = no rtk
led flash weak = xbee>gps
 
it looks like still dont have rtk. how i can fix that problem

clive1 replied 8 months ago

The BASE is going to need to be in TIME mode to send RTCM3 data
Enable UBX-NAV-PVT, check mode
Use UBX-CFG-TMODE3 to set a fixed location or start a Survey-In process
Check UBX-NAV-SVIN to check state of survey

werner rosendaal answered 8 months ago

where is can find the ubx-nav-pvt   and ubx-nav-svin
 base  on ubx-cfg-tmode3  he is on survey-in mode
rover is  on disabled
 
the base have a 3d fixmode
the rover have a 3d and some times 3d-dgnss or 3d-dgnss-float  fixmode
if the rover have a 3d-dgnss fixmode then de no rtk led wil flash 
what means that
 
 
 
 

clive1 replied 8 months ago

I would be using uCenter to configure and review performance during setup and integration work.Black boxing the diagnostics via LEDs is too crude to get specific answers.

werner rosendaal answered 8 months ago

ah zo thx.
 
where i must look at

Ardusimple Staff replied 8 months ago

Dear werner,

Try the following checklist:
1. Start with the base station. Enable UBX-NAV-PVT. Is the base station in TIME mode?
1A. If no, check survey-in status with UBX-NAV-SVIN. Wait until it’s finished.
1B. If yes, now you can go to the rover.

2. Check if it’s receiving RTCM corrections. Look for UBX-RXM-RTCM, right click, “enable message”. Do you see RTCM messages once per second?

clive1 replied 8 months ago

If the Base is not working and generating the right messages no amount of fiddling at the Rover end will fix the problem.
Need to work on the SOURCE of the data first, and then check its transmission and reception across the radio link.

werner rosendaal answered 8 months ago

 
where i can find ubx-nav
and ubx-rxm
i could find it

clive1 replied 8 months ago

uCenter -> Message View
Navigate in message tree to those of interest. They are reporting information that will help understand / diagnose the issues.
https://www.u-blox.com/sites/default/files/u-center_Userguide_%28UBX-13005250%29.pdf

werner rosendaal answered 8 months ago

thx. ok i fount it. but i see no time mode see only 3d fix on the base
on ubx nav svin is by status aborted
 

Ardusimple Staff replied 8 months ago

aborted usually means that you moved the GNSS antenna while the survey-in process was going on. It is important to not move GNSS antenna of the base station once it’s powered.