Problem reading GPS data using raspberry pi 3

Q&A forumCategory: QuestionsProblem reading GPS data using raspberry pi 3
Oussama asked 1 year ago
Hello,
I have recently bought a raspberry pi 3 mode b+ with a simpleRTK2b.
So I followed the process described in the following link : https://www.ardusimple.com/connect-your-simplertk2b-to-a-raspberry-pi/ to connect my raspberry pi 3 with simplertk2b. When I launch the command gpsmon, I get some weird characters instead of NMEA sentences, can you help me please?

2 Answers
clive1 answered 1 year ago
Make sure to use 38400 baud, not 9600 baud like most GPS/GNSS systems by default
ousim97
replied 1 year ago

Do you have another solution please? I believe It’s a hardware failure..

ousim97 answered 1 year ago
Yes I’m sure I use the 38000 baud rate in the python code provided but I still get the same result (weird characters instead of NMEA sentences) .
clive1
replied 1 year ago

Capture the data to a file, using cat or whatever, and attach as a Google Drive or Dropbox
The UBX packets are binary, and not human readable ASCII. Check other baud rates.
Connect to a Windows PC using GPS+POWER, and check device configuration with uCenter

ousim97
replied 1 year ago

In putty, I tried different baud rates but none of them works.
For the u-center software, It shows no COM port in “Reiceiver –> Connection”.

ousim97
replied 1 year ago

[EDIT] The connection between the simplertk2b and my laptop is established (via network connection) but I still get “No Fix” in the u-center interface.

clive1
replied 1 year ago

Looks like it isn’t getting any data. Open a Binary View
Ideally a) connect to the GPS+POWER port, and make sure you use the VCP Driver, and not the Windows Location/Sensor driver and API. If you don’t have a COM port coming up in Device Manager you’re doing it wrong.
b) Record the data you’re seeing on the RPi side, so some determination of what the weird characters signify, probably UBX packet data that isn’t human readable, but binary

ousim97
replied 1 year ago

Hello,
I installed the both drivers listed in this document https://www.u-blox.com/sites/default/files/products/documents/u-blox-GNSS-Sensor-and-VCP-Device-Driver_UserGuide_%28UBX-15022397%29.pdf (vcp and gnss sensor drivers) but the GNSS sensor driver does not appear in the device manager.
[EDIT] The virtual COM port (COM3) appears in the device manager.

ousim97
replied 1 year ago

[EDIT 2] For information, no Com port is showing in u-center .

ousim97
replied 1 year ago

Finally, It works, I got a 3D fix .. I had just to change the usb cable.
But now, I can’t visualize the NMEA sentences in text console. How to fix that please?

clive1
replied 1 year ago

This is all very hard to diagnose with this level of specificity..

You’re connected to the GPS+POWER connector, you have a workable COM port?

Open the Packet View in uCenter, what is it showing?
Go into Message View and enable the NMEA messages you want to see. You should be able to right click and enable them if they are not already being output.

In Windows only one application can open the COM port at a time. If you close uCenter, you can open a Terminal application with the same COM and baud settings.

ousim97
replied 1 year ago

Thanks a lot, It worked..
I’ll be back If I have more questions.
Thanks again for your help.