X

Possible Pixhawk Startup Problem

Q&A forumCategory: QuestionsPossible Pixhawk Startup Problem
yunus.emre.arslantas asked 7 months ago
Dear community and Ardusimple team,
We have bought simpleRTK2B-F9P V3 + 4G NTRIP Client for our positioning needs. I have followed the tutorial for the settings and when I connect the receiver to computer over USB port and use U-center (v21_09), i can see that the receiver works as charm and I get RTK Fix accuracy.
I have problems with Pixhawk 4 communication. I am using PX4 (Stable Release v1.12.3). When I connect the receiver to Pixhawk, I can only get 3D accuracy. Basically, the GPS is working without RTK corrections. If I start the receiver with U-center and later attach the Pixhawk after having RTK Fix in Ucenter, I can see that, I achieve RTK Fix accuracy in Qgroundcontrol also for some seconds and later switch to DGPS accuracy in Qgroundcontrol.
I think, during the startup Pixhawk is overwriting some parameters of the receiver (maybe switching the mode) and therefore due to the resulting settings, RTK accuracy cannot be achieved. Any other users have similar behaviour ? Or how I can protect the parameters to be overwritten by Pixhawk? Or is there any other possible solution? Thanks in advance.
Ardusimple
Staff replied 7 months ago

By default ArduPilot autoconfigures the GPS.
You should set this parameter: GPS_AUTO_CONFIG to 0.
Can you please check again?

yunus.emre.arslantas
replied 7 months ago

I am using PX4 stack instead of Ardupilot. Unfortunately, PX4 doesn’t have GPS_AUTO_CONFIG or similar parameter. I checked the GPS related parameters following your suggestion again and resetted them to default, so that the Pixhawk doesn’t configure the receiver after startup.

yunus.emre.arslantas
replied 7 months ago

When I use UART 2 for communication between Xbee and receiver, and configure the ports also from U-Center, the connection seems to be working. However, i need to attach Pixhawk after I start the GPS. If I start Pixhawk first, I need to press reset button on the receiver to have RTK Fix. Any clue how I can disable the input from Pixhawk to receiver in U-center?

root
Staff replied 7 months ago

Ok, we see two possible problems:
1) Pixhawk power supply is not strong enough to feed the simpleRTK2B and the modem at the same time
2) PX4 is somehow changing the configuration of the simpleRTK2B

When you connect Pixhawk first, do the modem LEDs do something?
To discard problem 1), can you please power the simpleRTK2B with a USB wall power supply (like the one you use to charge your smartphone) or a USB battery pack and then, connect it to the autopilot?
If you get RTK Fix, this is the problem.
You will need to power the simpleRTK2B+modem with an independent power supply (via USB or directly via the Arduino 5V pins).

If you don’t get RTK Fix, then PX4 is changing the configuration.
Let’s wait for your test to continue the troubleshooting.

Regards,
ArduSimple Team

yunus.emre.arslantas
replied 7 months ago

Thanks a lot for the recommendations. I tried the protocol that you have described regarding the first problem.

1- Followed your suggestion. I connected the simpleRTK2B directly to the autopilot. Power to the receiver is provided by USB battery pack. Power to the autopilot is provided by another USB battery pack. Qgroundcontrol is on, and there is telemetry between the autopilot and the computer. I provided power to the receiver and 1-2 seconds later, powered on the autopilot. In this configuration I had RTK Fix.

2- I connected the simpleRTK2B directly to the autopilot. Power to the receiver is provided by the autopilot. Power to the autopilot is provided by USB battery pack. Surprisingly, in this configuration I had RTK Fix too. So a battery pack is enough to power on both boards with telemetry.

3- I connected the simpleRTK2B directly to the autopilot. Power to the receiver is provided by the autopilot. Power to the autopilot is provided by USB cable, connected to the computer. First I turn on the Qgroundcontrol and later provide power to autopilot. In this configuration I had no RTK Fix. I reset the receiver while autopilot is on and I had RTK Fix. I can’t explain here. Maybe USB connection is withdrawing more power during startup. Mavlink is hindering a normal startup of the receiver. But if Mavlink is the problem, why setup 1 and setup 2 worked? Maybe due to the telemetry, some request from Qgroundcontrol is delayed and the receiver started normally.

4- Same test in 3. I started Qgroundcontrol 30 seconds after I turn on the autopilot and the receiver. I had RTK Fix.

The problem seems to be the power when a USB cable is connected and Qgroundcontrol is on. But of course these settings are applied when Xbee to GPS communication is using UART2 and port settings are done accordingly in U-center. simpleRTK2B is not working out of the box with PX4 without changing UART settings. Maybe this could give some hints for future users.

Thanks a lot again.

 

root
Staff replied 7 months ago

Hi again, now that I read QGroundControl it changes everything!
QGroundControl changes automatically the ZED-F9P configuration by default and turns it into a base station.
Can you please open QGroundControl, connect to your autopilot as usual, go to the main menu > Application Settings > General > AutoConnect to the following devices > Unselect RTK GPS.
Restart everything and try to repeat your tests.

Want to learn more about GPS/RTK?

1. Our engineering team will contact you to solve any questions
2. We will keep you updated about promotions and new product releases
3.You will only hear from us when we have important news, we won’t spam your email