NTRIP Caster is dropping connection | WIFI NTRIP Master

Q&A forumCategory: QuestionsNTRIP Caster is dropping connection | WIFI NTRIP Master
Tobias Kellner asked 6 months ago
Hey all,
I’m fairly new to the RTK-GNSS stuff and just received my SimpleRTK2B and WIFI NTRIP Master board. 
I’m trying to connect to the NTRIP Caster of my Institution via the NTRIP Client of the xbee board. It’s able to establish a connection only to be dropped by the caster a few ms later, as the log tells.
 
The caster works flawlessly via u-center and a smartphone app. I figured with a lot of trials that my NTRIP caster needs to have a inital localization message sent to permanently establish the connection. How do I get Wifi NTRIP Master to do so and what kind of configurations do I need to make within u-center? Currently it’s already outputting something to the NTRIP Caster (it says 4,6kb out (14B/s) on the NTRIP client Panel of the NTRIP Master
At the UART Panel of the NTRIP WIFI Master it’s also saying 65,1kB in / 14,5kB out communication between xbee and ublox should therefore work (in theory)
Current configuration file used: simpleRTK2B_FW130_Rover_sends_GGA_to_base_1Hz-00.txt
WIFI NTRIP Master FW: v0.5.4
Thanks for your help

3 Answers
Ardusimple Staff answered 6 months ago
Hi you seem to be doing things correctly, the configuration file you are using already enabled GGA to base, and this should be enough for the WiFi to send this to the caster.

  1. Check that you are not using your credentials simultaneously from the WiFi NTRIP Master and another device.
  2. Check in u-center UBX-MON-MSGPP which kind of data is the zed-f9p receiving.
  3. If above doesn’t help, start by sharing the WiFi logfile (from POWER+XBEE port at 115’200bps), and a screenshot of your WiFi configuration page can also help.

Tobias Kellner answered 6 months ago
Hey thanks for the fast reply.

I’ve double checked that it’s the only client for now but without any success – so: 
The Logoutput of POWER+XBEE:

LOGOUTPUT:
10:29:28.274 -> $PESP,INIT,START,v0.5.4,POWERON*55
10:29:30.789 -> $PESP,WIFI,AP,SSID,ESP_XBee_1C94B9,V,O*5A
10:29:30.789 -> $PESP,WIFI,AP,IP,192.168.4.1/24*08
10:29:30.789 -> $PESP,WIFI,STA,CONNECTING,Tobis-Castle,P,F*0B
10:29:31.027 -> $PESP,INIT,COMPLETE*05
10:29:32.065 -> $PESP,WIFI,STA,CONNECTED,Tobis-Castle*5C
10:29:37.269 -> $PESP,WIFI,STA,IP,192.168.2.86/24,192.168.2.1*62
10:29:37.269 -> $PESP,NTRIP,CLI,CONNECTING,rtcm.royal-gps.com:2101,AUTO*4D
10:29:37.410 -> $PESP,NTRIP,CLI,CONNECTED,rtcm.royal-gps.com:2101,AUTO*0C
10:29:47.441 -> $PESP,NTRIP,CLI,DISCONNECTED,rtcm.royal-gps.com:2101,AUTO*52
10:29:47.441 -> $PESP,NTRIP,CLI,CONNECTING,rtcm.royal-gps.com:2101,AUTO*4D
10:29:47.535 -> $PESP,NTRIP,CLI,CONNECTED,rtcm.royal-gps.com:2101,AUTO*0C
10:29:57.565 -> $PESP,NTRIP,CLI,DISCONNECTED,rtcm.royal-gps.com:2101,AUTO*52
10:29:57.565 -> $PESP,NTRIP,CLI,CONNECTING,rtcm.royal-gps.com:2101,AUTO*4D
10:29:57.754 -> $PESP,NTRIP,CLI,CONNECTED,rtcm.royal-gps.com:2101,AUTO*0C
10:30:07.735 -> $PESP,NTRIP,CLI,DISCONNECTED,rtcm.royal-gps.com:2101,AUTO*52
10:30:07.735 -> $PESP,NTRIP,CLI,CONNECTING,rtcm.royal-gps.com:2101,AUTO*4D
10:30:07.924 -> $PESP,NTRIP,CLI,CONNECTED,rtcm.royal-gps.com:2101,AUTO*0C
10:30:17.912 -> $PESP,NTRIP,CLI,DISCONNECTED,rtcm.royal-gps.com:2101,AUTO*52
10:30:17.912 -> $PESP,NTRIP,CLI,CONNECTING,rtcm.royal-gps.com:2101,AUTO*4D
10:30:18.054 -> $PESP,NTRIP,CLI,CONNECTED,rtcm.royal-gps.com:2101,AUTO*0C
10:30:28.038 -> $PESP,NTRIP,CLI,DISCONNECTED,rtcm.royal-gps.com:2101,AUTO*52
10:30:28.038 -> $PESP,NTRIP,CLI,CONNECTING,rtcm.royal-gps.com:2101,AUTO*4D
10:30:28.180 -> $PESP,NTRIP,CLI,CONNECTED,rtcm.royal-gps.com:2101,AUTO*0C
10:30:38.196 -> $PESP,NTRIP,CLI,DISCONNECTED,rtcm.royal-gps.com:2101,AUTO*52
10:30:38.196 -> $PESP,NTRIP,CLI,CONNECTING,rtcm.royal-gps.com:2101,AUTO*4D
10:30:38.385 -> $PESP,NTRIP,CLI,CONNECTED,rtcm.royal-gps.com:2101,AUTO*0C
10:30:48.411 -> $PESP,NTRIP,CLI,DISCONNECTED,rtcm.royal-gps.com:2101,AUTO*52
10:30:48.411 -> $PESP,NTRIP,CLI,CONNECTING,rtcm.royal-gps.com:2101,AUTO*4D
10:30:48.554 -> $PESP,NTRIP,CLI,CONNECTED,rtcm.royal-gps.com:2101,AUTO*0C
10:30:58.566 -> $PESP,NTRIP,CLI,DISCONNECTED,rtcm.royal-gps.com:2101,AUTO*52
10:30:58.566 -> $PESP,NTRIP,CLI,CONNECTING,rtcm.royal-gps.com:2101,AUTO*4D
10:30:58.707 -> $PESP,NTRIP,CLI,CONNECTED,rtcm.royal-gps.com:2101,AUTO*0C


Screenshot of MSGPP:
MSGPP Screenshot
 
Wifi-Config Screenshot:
Wifi-Config Screenshot
 
 
However I managed to get it running with a workaround: With the help of STRSVR I can connect to the NTRIP caster and reroute the NTRIP Stream via TCP to the xbee Socket Client. This works fine but it’s not the cleanest solution in my eyes. One finding with this: STRSVR can only connect to the ntrip server if NMEA cycle is checked (to 10ms) and some initial coordinates are set up:
STRSVR Screenshot
 
I hope you can see the screenshots.

Ardusimple
Staff replied 6 months ago

Thanks for the details. Definitely seems GGA is not arriving to the server with the WiFi.
1. Is your GPS configuration sending GGA at 115’200bps to the UART connected to the WiFi? How do you confirm this?
2. The WiFi configuration section for the UART is blurred on your picture, I wonder if you changed any default setting there?

Tobias Kellner answered 6 months ago

Hi
I think the GPS is sending GGA to the UART. I confirmed it with checking what the WIFI NTRIP Master is outputting via the TCP Socket. With a simple TCP Client connected to the xbee wifi board the output is as follows:

Connected to 192.168.2.86 on Port 13
Received b’$GNGGA,090149.00,47********,N,009**.*********,E,5,12,0.66,434.078,M,47.477,M,1.0,0000*64\r\n’
Received b’$GNGGA,090150.00,47********,N,009**.*********,E,5,12,0.66,434.076,M,47.477,M,1.0,0000*66\r\n’
Received b’$GNGGA,090151.00,47********,N,009**.*********,E,5,12,0.74,434.081,M,47.477,M,1.0,0000*6A\r\n’
Received b’$GNGGA,090152.00,47********,N,009**.*********,E,5,12,0.68,434.097,M,47.477,M,1.0,0000*61\r\n’
Received b’$GNGGA,090153.00,47********,N,009**.*********,E,5,12,0.66,434.098,M,47.477,M,1.0,0000*68\r\n’
Received b’$GNGGA,090154.00,47********,N,009**.*********,E,5,12,0.66,434.103,M,47.477,M,1.0,0000*69\r\n’
Received b’$GNGGA,090155.00,47********,N,009**.*********,E,5,12,0.76,434.089,M,47.477,M,1.0,0000*6A\r\n’
Received b’$GNGGA,090156.00,47********,N,009**.*********,E,5,12,0.71,434.082,M,47.477,M,1.0,0000*61\r\n’

Note: I edited the **** into the output afterwards.

Do you have a better way to ensure that GGA is actually sent to the xbee board?

I haven’t changed any UART configurations.

I’m fairly sure there’s just one slight mistake but don’t find it.

Ardusimple
Staff replied 6 months ago

At this point I can only think of incorrectly typed password / username, or a space added by mistake to one of this fields.
When this happens to me, I go one step back and I try:
1. Another caster without password and without GGA requirements (like rtk2go)
2. Another caster with user/password but without GGA requirement
3. Another caster with user/password and with GGA requirement

Usually then I found where was the problem. I see also you are using the latest WiFi version which is a development drop and not the official one. The feedback so far is good with this one, but we still recommend the 0.5.2 as fully tested. Try above 1,2,3 before going for this last attempt with the firmware change.

Hope this brings you closer to a solution.

Want to learn more about GPS/RTK?

1. Our engineering team will contact you to solve any questions
2. We will keep you updated about promotions and new product releases
3.You will only hear from us when we have important news, we won’t spam your email