No GPS reception on two boards with ANN-MB-00-00 antenna

Q&A forumCategory: QuestionsNo GPS reception on two boards with ANN-MB-00-00 antenna
Michael Torrie asked 1 week ago

This afternoon I had a working SimpleRTK2 board on my desk.  I took it and another antenna (all ANN-MB-00-00 IP65 antennas) I’ve used before outside for a test.  Got no RTCM messages from it through my radio link.  Plugged a laptop in and although I could communicate with the F9P and see and set parameters, no GPS reception at all.  Brought it back inside and hooked it to the antenna on my window sill and nothing.  Got out my spare SimpleRTK2 and connected it to my window antenna and it found satellites right away and got a 3D lock quickly.  So I soldered up this second board, tested it again, this time talking to my radio link, and it worked. So I took it outside, reconnected it to the antenna I had taken outside previously, and nothing.  Same exact symptoms.  Worried now, I came in and got the antenna I knew was just working and tried that, but nothing. So now I’ve got two non-working SimpleRTK2 boards, and apparently an antenna that causes the problem.  But now I’m not even sure about the second antenna. Could the bad antenna have fried the RF circuitry in the second board which would then damage the second antenna. I don’t want to ruin any more F9Ps! 
How can I tell if the antenna is bad?  Is there some kind of test I can do with it?  These are supposed to be active antennas, right? What makes them active?
Hope you can shed some light.

Ardusimple Staff replied 1 week ago

Hi Michael,
We are sorry to hear this news. From your description it seems like you have a defective ANN-MB antenna. If you could send us an email to info@ardusimple.com with above description we will ask you a few more questions to confirm and then we can start the return process to repair/replace the material.

2 Answers
torriem answered 1 week ago

I found the root cause of the problem which was a bad/defective SMA connector on the ANN-MB-00-00 antenna.  Somehow the signal pin inside the SMA connector got pushed back into the plastic.  This created a dead short to the outer ground, which fried the RF stage on both SimpleRTK2 boards.  I can pull the pin back out with needle nose pliers, but I have no idea what the short has done to the antenna and the SMA connector is of course now completely bad and cannot be trusted.  I thought the F9P can detect and antenna short and disable things.
I’m think the other antenna is still okay but I’m definitely going to write off the antenna with the bad SMA connector.  Can you tell me how to test the antenna, short of plugging it into another board and risking burning it out?  It’s an active antenna; does it have a certain continuity through it?
$800 CAD lost to what appears to be a defective SMA connector kind of burns!  Puts my project on indefinite hold for now.

torriem answered 1 week ago

Thanks for your response! That’s very generous of you. I’m sending an email as requested.