MosaicHAT does not get recognized by computer

Q&A forumCategory: QuestionsMosaicHAT does not get recognized by computer
Max Polzin asked 2 months ago
My MosaicHAT does no longer get detected reliably by any computer.
Sometimes the MosaicHAT gets detected as “[Freescale SemiConductor Inc SE Blank 6ULL]” device. 
Sometimes it gets detected as “Septentrio USB Device”, but no rndis_host or cdc_ethernet device or mass storage or tty devices are initialized and the device resets the connection after a couple of seconds. and throws errors like “device descriptor read/64, error -110” or “device not accepting address 19, error -62”.
Sometimes, the device is not recognized at all.
To me it seems like the chip is no longer booting up properly. From the erratic behavior which I observe, I believe the hardware is somehow malfunctioning. How can I verify that my MosaicHAT is not bricked?
 
Output dmesg command on Ubuntu 22.04
Max Polzin
replied 2 months ago

The blank lines in the image indicate where I plugged out the device and replugged after some time.

Max Polzin
replied 2 months ago

If the device gets detected (only sometimes the case), lsusb detects the device in recovery mode:

Bus 002 Device 012: ID 15a2:0080 Freescale Semiconductor, Inc. i.MX 6ULL SystemOnChip in RecoveryMode

1 Answers
Ardusimple Staff answered 2 months ago
Dear customer,
Thank you for the email and description. Seems the Mosaic X5 module is bricked. Please contact my colleagues at info@ardusimple.com including a picture where the label of the module can be seen.
Max Polzin
replied 2 months ago

Thank you very much for your incredibly fast response. I wrote a message with an attached picture of the module to your colleagues.

Want to learn more about GPS/RTK?

1. Our engineering team will contact you to solve any questions
2. We will keep you updated about promotions and new product releases
3.You will only hear from us when we have important news, we won’t spam your email