I think my 4g NTRIP Client is not configured properly.

Q&A forumCategory: QuestionsI think my 4g NTRIP Client is not configured properly.
Jack asked 2 years ago
So I followed the hookup guide at:

4G NTRIP Client hookup guide


And it all went all right, when I finished the 4G Ntrip client was blinking red very fast and the blue “GPS FIX” led was blinking too, same keeps happening after restart.
Now, when I connect the Rtksimple to u-center, I can see that the fix mode is 2D/3D which changes to 2D/3D/GNSS/FLOAT If I connect the Ntrip client option that comes in u-center , making me think that the 4g ntrip client is not configured properly, because if it were I would be getting the 2D/3D/GNSS/FLOAT fix mode from the start. 
I’ve been tinkering with the configuration view in u-center and in the MSG(Message) tab deactivated all messages except F0-00 NMEA GxGGA since its the only one I need to read. Could that be a problem? Is there any way to see from u-center if the 4G NTRIP Client is configured properly? If not how do I make it work?

Ardusimple
Staff replied 2 years ago

Hi Jack,
It is important to confirm that GGA is being sent to XBee socket at 115’200bps. Check your UBX-CFG-PRT configuration and the switch under the 4G NTRIP.

If you are connected via POWER+XBEE USB connector and open a terminal program (like u-center, view > text console) at 115’200bps, the 4G NTRIP will output what is going on, it you paste here what you see in the terminal we might be able to help.

Jack
replied 2 years ago

The switch under the 4G NTRIP is put to XBEE TO GPS UART1.
How do I go about checking the UBX-CFG-PRT configuration, is it u-center or Telit At Controller?
If connect the POWER+XBEE USB to the text console as you said nothing comes up in the screen.

Ardusimple
Staff replied 2 years ago

Hi Jack,
Sorry my explanation was not clear. I restart:

If they switch below 4G is put to XBEE to GPS UART1:

First With GPS+POWER, from u-center > View > Message View > UBX-CFG-PRT > UART1 should be configured at 115’200bps. Remember to store the configuration permanently with UBX-CFG-CFG “save current configuration”.

Then with XBEE+POWER, from u-center with com port at 115’200bps > View > Text Console. Press XBEE RESET and wait for messages to come out. Make a screenshot / copy-paste the text that appears 10 seconds after boot.

Jack
replied 2 years ago

Thanks for the reply!
I did what you asked and what comes out is:
First two $GNGGA messages with my position and then:
11:09:31 $GNTXT,01,01,01,NMEA unknown msg*46
11:09:31 $GNTXT,01,01,01,NMEA unknown msg*46
11:09:31 $GNTXT,01,01,01,NMEA unknown msg*46
Continously, sometimes it sends the $GNGGA message again.
After some time of the same $GNTXT messages it shows the data of the config file I sent to the 4G NTRIP client through the Telit AT Controller.
After that:
11:09:40 $GPTXT,WARNING: NO INPUT STREAMS FROM NTRIP SERVER IN 10s, PLEASE CHECK CREDENTIALS AND GPS RECEIVER CONFIGURATION*66

Jack
replied 2 years ago

Also sometimes when I restart the device nothing comes in the Text Console, so I have to restart the SimpleRtk repeatedly until text start appearing in the console.

Jack
replied 2 years ago

Happens sometimes too that after some time it gives the message:
12:09:49 $GPTXT,WARNING: NO INPUT STREAMS FROM NTRIP SERVER IN 10s, PLEASE CHECK CREDENTIALS AND GPS RECEIVER CONFIGURATION*66
And stops so I have to restart it again. This happens despite giving the right position minutes before.
Also whatever test I make the message:
12:09:49 $GNTXT,01,01,01,NMEA unknown msg*46
Is the most common message I get sometimes covering the screen completely, with the $GNGGA appearing only sometimes.

Ardusimple
Staff replied 2 years ago

Hi Jack,
The topic about sometimes nothing comes in the text console after 10 seconds of pressing the XBEE RESET button, this usually happens when you are using a low quality usb cable or a power source that doesn’t give enough power. try with using 2 usb cables at the same time.

As for the configuration GPTXT warning, it would be good if you could paste all the sequence of messages since boot, only the message above can be several things. You can put #### on the positions if you don’t want to publish them.

Can you upload here or send to info@ardusimple.com the configuration of your gps receiver, we will check if it’s ok.

Jack
replied 2 years ago

Ok, after one reset the first thing that comes is:
12:25:50 $GNGGA,##########################
12:25:50 $GNTXT,01,01,01,NMEA unknown msg*46
12:25:50 $GNTXT,01,01,01,NMEA unknown msg*46
12:25:50 $GNTXT,01,01,01,NMEA unknown msg*46
12:25:51 $GNGGA,##########################
12:25:51 $GNTXT,01,01,01,NMEA unknown msg*46
12:25:51 $GNTXT,01,01,01,NMEA unknown msg*46
12:25:51 $GNTXT,01,01,01,NMEA unknown msg*46
12:25:51 $GNTXT,01,01,01,NMEA unknown msg*46
12:25:51 $GNTXT,01,01,01,NMEA unknown msg*46

And keeps going on until it gives me
12:26:01 $GPTXT,ARDUSIMPLE 4G NTRIP CLIENT FW V1.2-20200625*32
followed by $GPTXT that shows the data of the configuration file that contains the Ntrip authentication files. After that it stops until I restart it.
I sent the config file to the email provided.

Jack
replied 2 years ago

While doing tests I realized that now while I look at the POWER + GPS connection with u-center it does appear that my fix mode is 2D/3D/GNSS/FLOAT sometimes but this is temporary and dissappears quickly. Also the behavior of the POWER+XBEE is the exact same as I described before.

Ardusimple
Staff replied 2 years ago

Hi Jack,
Thanks for sending the configuration file. Configuration file is ok if your switch is connected to XBEE to GPS UART1. (1) Can you confirm that this is like this?

Note that you disabled all messages but GNGGA, so it’s normal that you only see the position and fix flags, but you don’t see satellite bars or any other info.

If (1) is yes, next step I recommend is to upgrade the Telit firmware. Latest version is FW1.53 (you have FW1.2), and many compatibility for NTRIP casters have been added, there is high probability that the problem is there.

clive1
replied 2 years ago

>>$GNTXT,01,01,01,NMEA unknown msg*46
In bounding NMEA sentences from another source rather than a pure RTCM3 stream

Jack
replied 2 years ago

My switch is connected to XBEE to GPS UART1.
All the messages besides GNGGA were disabled deliberately, since they all are going to another device and GNGGA is the only one that is relevant to him.
Ok, I’m going to update the firmware now.

Jack
replied 2 years ago

I’m having trouble updating since Telit AT Controller freezes every time I open the terminal. I guess all the $GNTXT are flooding the console screen.

Ardusimple
Staff replied 2 years ago

To perform the update remember to move the switch to XBEE to GPS UART2. The same applies to load the parameters file.

Jack
replied 2 years ago

I disabled all the information messages in the INF (Inf Messages) tab and that cleaned the $GNTXT,01,01,01,NMEA unknown msg*46 messages.

Jack
replied 2 years ago

Since I also get the 2D/3D/GNSS/FLOAT fix when I view the POWER + GPS text console I think this problem is solved.

Ardusimple
Staff replied 2 years ago

Great, thanks for the update!

Want to learn more about GPS/RTK?

1. Our engineering team will contact you to solve any questions
2. We will keep you updated about promotions and new product releases
3.You will only hear from us when we have important news, we won’t spam your email