how to configure XBee Bluetooth?

Q&A forumCategory: Questionshow to configure XBee Bluetooth?
geom asked 1 month ago

Hi,
I know that You’re selling a preconfigured XBee Bluetooth module in Your shop. I have one lying around (XBee Bluetooth with HC-05 with 3.3V) and want to use it with the ArduSimple board. I’ve configured it to use a baudrate of 115200 and set the same in u-center on UART2.
In u-center I enabled UART2, set RTCM3 as Inprotocol and UBX and NMEA as OutProtocol in UBX-CFG-VALSET. These settings are seen in the UBX-CFG-PRT menue and can also be seen in the new Generation 9 configuration view.
My XBee BT connects without issues to my tablet, but there is no incoming data.
When I look at the UBX-MON-IO, only USB and UART1 shows traffic on the TX, UART2 stays at 0.
On the board I’ve tried already both: connecting the 3.3V output to the board to the IOREF pin AND without this connection.
Is there someting I’m missing? 

geom replied 1 month ago

Hi,
the ublox integration Manual says that the UART2 shouldn’t be used the way I intended to use it (as primary host connection):
“UART2 is intended to convey correction messages to the module and will only accept RTCM and NMEA protocols and should not be used as a primary host connection.”
But as far as I understood the intention of Your XBee Bluetooth module it is to offer a simple primary connection without restrictions in terms of protocols. Or am I wrong?

2 Answers
Ardusimple Staff answered 1 month ago

Hi geom,
As u-blox states, UART2 supports RTCM and NMEA protocols but not UBX.
If you need UBX, you can connect your module to UART1

geom replied 1 month ago

OK, so far. But is it possible to connect the BT module using the XBee socket to UART1 since actually this socket is linked to UART2? It would be great to have this opportunity since the XBee socket gives a very stable and compact connection to the board without the need to wire a separate module in a compact enclosure.

Ardusimple Staff replied 3 weeks ago

Hi geom,
Unfortunately the XBee socket is connected physically to UART2 so it is not possible to reroute it to UART1.
You could try to put wires from UART1 TX/RX to UART2 TX/RX in the Arduino headers and also to power the IOREF pin.
Then in u-center you should disable all protocols for UART2.
Then you may be able to use the XBee socket with UART1 (we have never tried such configuration, if you do, let us know if it works)

geom answered 3 weeks ago

Hi,
thanks for Your answer. After trying a bit it finally works!
I disabled all protocols on UART1. But it works only after disabling the whole UART2 port in u-blox!
Set the power to 3.3V on IOREF (connected the 3.3V out to IOREF)
Connected UART1 TX1 => RX2 and RX1 => TX2.
The BT on XBee socket now sends NMEA, RTCM and UBX, an can recieve whatever UART1 allows. 
Great. Thanks a lot for the excellent work You’re doing.
 

Ardusimple Staff replied 3 weeks ago

Hi geom,
Thanks for the good news, we really appreciate your confirmation when things finally work.

geom replied 3 weeks ago

Sorry, I wrote in my post ‘ I disabled all protocolls on UART1’ should be ‘UART2’!
Actually it works with LEFEBURE (RTCM3 / NMEA) and with MapitGis-NTRIP-Client (UBX).