How to config HC-06 with smartphone?

Q&A forumCategory: QuestionsHow to config HC-06 with smartphone?
MS asked 6 months ago

Hello, is a way to config the HC-06 Modul with a smatphone (android)? The connection works but no GPS data is transmitted.

6 Answers
Ardusimple Staff answered 6 months ago

Hi MS,
Have you tried following steps on: https://www.kickstarter.com/projects/simplertk2b/simplertk2b-the-first-multiband-rtk-shield-based-o/posts/2297339?lang=es ? Make sure you configure the right baudrate.
Note that we have now available in our webshop a pre-configured bluetooth module that you can connect to the XBee socket: https://www.ardusimple.com/product/bluetooth-module/ 

MS answered 6 months ago
Now it's working. 
PUBX 41 >UART2>Baudrate 9600.......(HC-06 > 9600)

But the baudrate of the HC-06 I can not change. AT commands without answer.
Ardusimple Staff replied 6 months ago

With the HC-05, you need to connect the Key pin to Vcc to enable AT command mode.
With the HC-06, this should not be necessary, since AT mode is enabled by default.
Make sure to add /r/n (CR+LF) to all your commands and try with 9600bps and 38400bps.

MS answered 6 months ago
How is the baud rate of the Bluetooth module set in your shop?
Ardusimple Staff replied 6 months ago

We set it at 38400bps to match the default configuration of UART2 in the ZED-F9P.
We define it by sending this command: AT+UART=38400,0,0\r\n
We can check the baudrate with this command: AT+UART?\r\n

Ardusimple Staff replied 5 months ago

Hi MS, did you solve it?

MS answered 4 months ago

Hello I have a new problem.

After a reset of the board I only have a Bluetooth connection with data when I am using the USB port with the PC and U box at the same time. If I use the Bluetooth connection without a PC, I have a Bluetooth connection but without GPS data. What is wrong in the settings?
Is there a config file which is designed for the use of HC-05 (shop) and lefebure (Android)?
Ardusimple Staff answered 4 months ago

Hello MS,
Have you checked if you have NMEA protocol in UART2 (out) and RTCM protcol in UART2 (in) enabled by default?
Let us know if you don’t know how to check this.