Change output rate

Q&A forumCategory: QuestionsChange output rate
rosagriculture asked 4 years ago
Hi,
On this tutorial: https://www.ardusimple.com/testing-simplertk2b-accuracy-in-rtk-base-rover-configuration/
It has the output rate at 5hz

  • simpleRTK2B configured to report data at 5Hz

I looked in UBlox U-Center under Messages – UBX – cfg – RATE:
configure rate 
But didn’t find a place to change it to 5hz.
Thanks,
Matt

Question Tags:
rosagriculture
replied 4 years ago

Or do I change the measurement period to 200 ms?

1 Answers

Best Answer

rosagriculture answered 4 years ago
Changing the Measurement Period to 200 ms updated the output rate to 5 hz.
akshaya.dayal
replied 2 years ago

I changed the measurement Period in U-center for an effective output rate of 10 Hz and saved settings to the device. However, I still get an output at 2 Hz. Is there something wrong I’m doing ? I am using the ublox ros driver as indicated here -> https://msadowski.github.io/ardusimple-ros-integration/ .
Changing the nav_rate parameter in the yaml file also doesn’t effect the output rate of the /gps/fix messages.

Want to learn more about GPS/RTK?

1. Our engineering team will contact you to solve any questions
2. We will keep you updated about promotions and new product releases
3.You will only hear from us when we have important news, we won’t spam your email