Change Output rate for dual-antenna heading setup

Q&A forumCategory: QuestionsChange Output rate for dual-antenna heading setup
akshaya.dayal asked 4 weeks ago

I am using the dual-antenna heading setup (simpleRTK2B+heading) . Currently the rover outputs position and heading data at 1 Hz. I want to increase that to 10 Hz .
I tried changing the measurement period under UBX – cfg – RATE to 100 ms but then I started observing outliers in the position data that was output (heading would jump > 100 degrees after every 4-5 output samples ) and even then the rate was not increased. Perhaps I need to change the UBX – cfg – RATE parameter in both of the boards (simpleRTK2B + simpleRTK2B Lite) ? Or is there some other way to achieve this ? 

1 Answers
clive1 answered 4 weeks ago

Pretty sure it is not rated for 10 Hz operation, check data sheets.
5 Hz should be viable
Make sure you don’t overwhelm the interfaces with data, you should cull all unnecessary messages. ie you don’t need GSV or UBX-NAV-SAT at more than 1 Hz. If you get a $GNTXT “txbuf alloc” type message you need to double check the message loading and balance.
Increase the baud rate for the RTCM3 data link between the modules.