Cant connect through IP address with Ucenter

Q&A forumCategory: QuestionsCant connect through IP address with Ucenter
beatified asked 2 months ago

I have the simpleRTK2B – Starter Kit LR.
I have had the serial to ip connection working just fine and was able to connect with Ucenter in the past.
I did have an issue where it seemed that the baud rate of the simpleRTK2B kept changing on its own so I would have to change the buad rate in my script to get things to work often.
But that isn’t my main issue right now. As of right now I cant seem to connect to the simpleRTK2B at all with Ucenter.
When I try to connect to it using the test.py script that is listed in the tutorials page I cannot get any intelligible output no matter what baud rate I set. The most intelligible data I get is from 115200 see the linked picture for that.

View post on imgur.com


But although I can “connect” using Ucenter I cannot get any sat info or location or anything like that.
And here is my script for socat
while true; do
socat tcp-listen:54321,reuseaddr /dev/serial0,b115200,raw,echo=0
done

Ardusimple Staff replied 1 month ago

Hi beatified,
Sorry we didn’t answer, I don’t know why we didn’t receive/see the notification email about a new question. Can you update us? What is status?

beatified replied 1 month ago

Yes I resolved it. I found that the baud rate setting in the config file you provide on the website is set to 38400 and the baud rate of my script was 115200 so I first needed to connect at 38400 and then edit the uart baud rate to 115200 and then I was able to connect at 115200. So the baud rate was changing because I was sending the default config file to the GPS reciever. I have since restored the config file and did nothing but change the baud rate and then re exported it so that I dont have to modify things any more if restoring the config.

Ardusimple Staff replied 1 month ago

Thanks for the update!