?  
Update (16/05/2022): We keep shipping worldwide and we have plenty of stock of all our products. Shop now.X

Bluetooth Module to Inject RTK in Mission Planner

Q&A forumCategory: QuestionsBluetooth Module to Inject RTK in Mission Planner
Rajpinderjit Singh asked 3 weeks ago
Hi,
I bought the Bluetooth module and connected it to the computer, it shows up as RTK_GNSS_815 and using the password 1234 I connect it to my computer.   When I connect the Bluetooth module, under Device Connections, I get “Standard Serial over Bluetooth link (COM3)” and “Standard Serial over Bluetooth link (COM4)”.  Using U-center, I changed the SimpleRTK2B Budget’s UART2 and it’s baud rate to UBX+RTCM3+NMEA and 115200.
In Mission Planner – Set up – Optional Hardware – RTK/GP Inject, I’m able to connect to COM4, but the input rate data is around 17 to 20bps.   (If I connect to COM10, which is the USB connection, I do get RTK inject with input data rate of 1850+bps).
Can the Bluetooth module be used to inject RTK into Mission Planner?  Do I need to increase the baud rate of the Bluetooth module?
root
Staff replied 3 weeks ago

Hi, did you uploaded the base configuration file to the simpleRTK2B?
Otherwise it will not output corrections.
Also, the default baudrate for our Bluetooth module is 38’400bps.
You should change it to 115’200bps following this tutorial: https://www.ardusimple.com/changing-the-baudrate-of-ardusimple-bluetooth-module/
After both changes everything should be ok.

Rajpinderjit Singh
replied 3 weeks ago

Thank you. I was partially successful. Here’s what I did
I connected the Bluetooth module to the SimpleRTK2B Budget board plugged in the USB cable (on the same side as the module) and connected it to the computer, it showed up as ComPort 6. I bridged the upper two pins of the Bluetooth module momentarily (the left blinking red led blinks a faster momentarily)

I then open up RealTerm (version 2.0.070). On the Display Tab, I check Half Duplex (I saw in a youtube video that you need this to have anything displayed on top). I then go to Port tab, choose Port 6, baud Rate 38400 and click Change.

I then go to Send Tab, type in AT in the upper left box, I checked the boxes next to +CR and +LF and I click “Send ASCII” (the top one). The screen shows ATCRLF, I click a few times and I finally get OKCRLF.

I then type in “AT+UART+115200,0,0” in the same box and +CR and +LF checkboxes are already checked and then I click Send ASCII, but I keep getting an error. Can you let me know what is going on here.

Also how can I verify that the baud rate has changed?
Thankyou

Rajpinderjit Singh
replied 2 weeks ago

If I go to Port tab, change baud rate to anything but 38400, then click Change. Then go to Send Tab, type in AT in top left box, click on the checkbox for +CR +LF, all I see is the ATCRLF (CRLF in a different smaller font) on the screen above, but no ERROR:CRLF and no OKCRLF message. I only get the few errors and OK message if I select Baud Rate to 38400 and click change. So it means the device is still on 38400 baud rate. I’m unable to change it. Please let me know if I’m typing something incorrectly. After I get the OKCRLF, I’m typing in “AT+UART+115200,0,0” in the same box and then clicking Send ASCII, and I keep getting ERROR:CRLF message.

root
Staff replied 2 weeks ago

Hi, the string should be:
AT+UART=115200,0,0
not
AT+UART+115200,0,0

Rajpinderjit Singh
replied 2 weeks ago

Thank you very much. That solved it. I entered “AT+UART+115200,0,0” and clicked ASCII and I got an error, I clicked twice again and I got an error and the 4th time it said OKCRLF.
Then to check if the baud rate of the Bluetooth module has changed, I then disconnected the power from SimpleRTK2B Budget board, plugged it back in, bridged the upper two pins, closed RealTerm and opened it up again, and now if I kept the Baud rate at 38400, there would be no responses, but if I change to 115200, I get either Error or OK response back, meaning the baud rate was successfully changed.

I then connected the Bluetooth to the computer, and in Mission Planner – Setup – RTK/GPS inject, select Com4 115200 and click connect and it connects.

Rajpinderjit Singh
replied 2 weeks ago

I just have one more question.

I’m seeing a lot more messages and satellites on the RTK/GPS Inject page if I connect via USB vs Bluetooth. Bluetooth is connected to UART2.

Should UART2 be set to RTCM3 or UBX+RTCM3+NMEA which is what UART1 and USB are set to in the U center.

Will that make any difference?

Thank you

root
Staff replied 2 weeks ago

You should load the configuration file to set your receiver as a base station.
This configuration file already has all details included.

Rajpinderjit Singh
replied 2 weeks ago

Thank you for all your help. The rover configuration file is set to send out RTCM3 via UART2

Want to learn more about GPS/RTK?

1. Our engineering team will contact you to solve any questions
2. We will keep you updated about promotions and new product releases
3.You will only hear from us when we have important news, we won’t spam your email