Ardupilot and configuration of simpleRTK2B Heading Kit

Q&A forumCategory: QuestionsArdupilot and configuration of simpleRTK2B Heading Kit
Koen Hertogh asked 9 months ago
Hi,
I have the simpleRTK2B Heading Kit (simpleRTK2B and simpleRTK2Blite).
To get to RTK accuracy, I would like to use this kit with my simpleRTK2B and Radio module Long Range (LR) – Europe. I would like to use it with my ArduRover.
I have tried to get it to work with the ardupilot tutorial but it didn’t work for me. Please help me to get a few thing clear and get this to work:

  • Is it true, that I just need 1 cable from my ardupilot module to the Pixhawk connector on the simpleRTK2B module on my rover? (on this simpleRTK2B are a simpleRTK2BLite and Radio mounted)
  • How do I configure the simpleRTK2B and simpleRTK2BLite modules of my rover? I have tried two ways, which one is the right one?
       1. Connect the big board (simpleRTK2B) to the pc with the USB cable and u-center. First put configuration file simpleRTK2B_FW113_HeadingKit_Rover_10Hz_Ardupilot.txt to the big board, and save it via the message view, and then put configuration file simpleRTK2B_FW113_HeadingKit_MovingBase_10Hz_Ardupilot.txt to the big board and save it via the message view (with the same usb-connection)?
       2. Connect the big board (simpleRTK2B) to the pc with the USB cable and u-center. First put configuration file simpleRTK2B_FW113_HeadingKit_Rover_10Hz_Ardupilot.txt to the big board, and save it via the message view, and then connect the simpleRTK2Blite-module to the pc with the XBee-to-USB adapter and put configuration file simpleRTK2B_FW113_HeadingKit_MovingBase_10Hz_Ardupilot.txt to this board and save it via the message view (with the same usb-connection)?
  • After this, what do I need to do to make sure this rover modules are working with an extra ground simpleRTK2B module to get RTK accuracy? Do I need to edit the configuration for this or is it plug and play? I have put the configuration file “Base” on the ground simpleRTK2B module and saved it. After connecting both the radios and the ardupilot to the modules, I’m not getting any GPS_Yaw in mission planner and the rover thinks it is on the GPS position of my Base-simpleRTK2B ground module… Are the mission planner parameters in the tutorial right or do I need to change some other parameters too?  
  • Do I need to connect the rover simpleRTK2B and simpleRTK2BLite modules individual to the ardupilot (with 2 cables)?

Hope to hear from you soon.
Kind regards,
Koen
 

root
Staff replied 7 months ago

Hi Koen,
Yes, you only need one cable from the simpleRTK2B to your Pixhawk.
The simpleRTK2Blite is mounted on top of the simpleRTK2B and the radio is mounted on top of the simpleRTK2Blite.

Regarding the configuration, option 2 is the correct one.

Please, read this tutorial and follow it step by step:
https://www.ardusimple.com/ardupilot-simplertk2bheading-configuration/

Want to learn more about GPS/RTK?

1. Our engineering team will contact you to solve any questions
2. We will keep you updated about promotions and new product releases
3.You will only hear from us when we have important news, we won’t spam your email