Which COM to use for MosaicHAT

Q&A forumCategory: QuestionsWhich COM to use for MosaicHAT
messfuchs asked 2 weeks ago
Dear ArduSimple Team!
I recently bought a mosaicHAT. I’m able to connect via Ethernet-over-USB and i can see the Septentrio Interface.
I also connected the HAT via GPIO pins but I cannot receive any NMEA from it.
Neither on https://github.com/septentrio-gnss/mosaicHAT nor on your Q&A I could find a reasonable solution for receiving NMEA from the HAT.
When I try to connect to /dev/ttyAMA0 nothing arrives. So what should i activate on the mosaic to transmit GGAs? Within the WebUI i activated NMEA-GGA-1 sec on COM1,2,3,4 but my connections does not showing up.
Do i have to use another Interface than COMx?
kind regards, Jiargei
 
Ardusimple
Staff replied 2 weeks ago

A few ideas to check:
If you are using wires instead of stacking on top of the Raspberry Pi:
1. That you are not crossing TX and RX and that you connected to the correct pins.
2. That you are also connecting GND
If you are stacking on top of your Raspberry Pi:
3. Did you use tty successfully with another shield?

messfuchs
replied 2 weeks ago

I attached the mosaicHAT straight to the Raspberry PI GPIO shield
Yes, the shield is working. I even can turn the HAT’s LEDs on and off. As described the Serial COM1 should point at the raspi shield, right?

Ardusimple
Staff replied 2 weeks ago

4. How do you confirm that NMEA output is correctly configured on COM1?
5. Do you have any other hardware to confirm that UARTs are enabled? Like an FTDI converter
6. Can you try wiring COM2 to see if you have the same problem? If there is a hardware problem it is unlikely that both COM1 and COM2 have the same issue.

messfuchs
replied 1 week ago

Ok, i found out it is COM1 (as it is described in the github docs of mosaicHAT). I got a NMEA info on my Raspberry PI 2, but no information on Raspberry PI 3 and PI 4. It didn’t work on Raspberry PI Zero (I tested 3 different pi-devices) neither.

I thought it could be the Power Supply. I’m using:

* PI-4 with the original 5V/3A (COM1 doesn’t work)
* PI-3 with a USB-Charger 5V/2.4A (COM1 doesn’t work)
* PI-2 with a Non-Name charger 5V/3A (COM1 works)

I’m using rtklib/str2str to test it:
str2str -in serial://ttyAMA0:11520:8:N:1

1 Answers

Best Answer

messfuchs answered 1 week ago
Hej!
I think I found a solution: on the Raspberry Pi 3 there is also a device /dev/serial0 which is the correct port! One strange thing, I cannot make it work with baud rate 115200, I had to decrease it to baud rate 57600 and lower to make it work!
So at least for my Pis:

  • Raspberry PI 2: /dev/ttyAMA0:115200
  • Raspberry PI 3: /dev/serial0:57600
  • Raspberry PI 4: /dev/serial0:57600

 

Ardusimple
Staff replied 6 days ago

Thanks for sharing! Will be useful for other users.
Strange about the baudrate limitations, it should work also at 115’200bps

Want to learn more about GPS/RTK?

1. Our engineering team will contact you to solve any questions
2. We will keep you updated about promotions and new product releases
3.You will only hear from us when we have important news, we won’t spam your email