Unable to filter GGA messages, NTRIP client sending all messages to server

Q&A forumCategory: QuestionsUnable to filter GGA messages, NTRIP client sending all messages to server
Suchit Sharma asked 1 month ago

Hi,
I am using SimpleRTK2B with NTRIP client using XBEE(Wifi NTRIP master). I use SAPOS service in Germany. I am receiving RTK corrections, but now my service provider calls me and says that my device is sending a lot more data than required, clogging their server and due to which they have to block my service. See below for example data their server is recieving.
I have tried to filter the messages in Ucenter Configuration View -> MSG(messages) -> F0-00 NMEA GxGGA on UART2 and USB, I have updated the firmware too , but the problem persists. Please help me solve this problem.
Data sent to server(they only need a GGA message):
$GNRMC,161014.00,A,5229.62499,N,01326.86332,E,0.007,,140920,,,F,V*1F
$GNVTG,,T,,M,0.007,N,0.012,K,D*3C
$GNGGA,161014.00,5229.62499,N,01326.86332,E,5,12,0.63,32.5,M,42.1,M,9.0,4095*59
$GNGSA,A,3,04,09,06,07,30,05,02,16,,,,,1.26,0.63,1.09,1*06
$GNGSA,A,3,74,75,65,82,76,66,81,,,,,,1.26,0.63,1.09,2*0A
$GNGSA,A,3,07,02,26,25,03,08,13,,,,,,1.26,0.63,1.09,3*04
$GNGSA,A,3,07,22,20,19,10,,,,,,,,1.26,0.63,1.09,4*00
$GPGSV,3,1,11,02,39,280,30,03,03,129,,04,34,076,43,05,21,303,13,1*6C
$GPGSV,3,2,11,06,36,221,45,07,54,175,44,09,74,073,48,16,21,062,42,1*67
$GPGSV,3,3,11,26,09,027,32,29,08,337,25,30,26,197,41,1*53
$GPGSV,3,1,11,02,39,280,,03,03,129,,04,34,076,30,05,21,303,09,6*67
$GPGSV,3,2,11,06,36,221,26,07,54,175,26,09,74,073,30,16,21,062,,6*68
$GPGSV,3,3,11,26,09,027,,29,08,337,,30,26,197,20,6*55
$GLGSV,3,1,10,65,42,091,40,66,62,314,42,67,12,290,18,72,02,101,09,1*78
$GLGSV,3,2,10,74,20,027,31,75,53,091,39,76,30,156,38,81,23,253,20,1*7D
$GLGSV,3,3,10,82,30,308,18,83,11,353,19,1*74
$GLGSV,3,1,10,65,42,091,28,66,62,314,30,67,12,290,,72,02,101,08,3*79
$GLGSV,3,2,10,74,20,027,,75,53,091,31,76,30,156,31,81,23,253,16,3*79
$GLGSV,3,3,10,82,30,308,,83,11,353,,3*77
$GAGSV,3,1,09,02,28,130,29,03,37,088,40,07,32,273,24,08,86,318,45,7*71
$GAGSV,3,2,09,13,28,234,31,24,08,022,26,25,34,069,41,26,32,296,15,7*78
$GAGSV,3,3,09,33,07,341,,7*4B
$GAGSV,3,1,09,02,28,130,,03,37,088,31,07,32,273,29,08,86,318,36,2*70
$GAGSV,3,2,09,13,28,234,,24,08,022,,25,34,069,34,26,32,296,,2*7D
$GAGSV,3,3,09,33,07,341,,2*4E
$GBGSV,3,1,10,02,02,106,,05,16,129,,07,22,060,36,09,10,070,17,1*77
$GBGSV,3,2,10,10,24,087,24,11,04,354,,12,18,308,,19,80,113,43,1*7B
$GBGSV,3,3,10,20,26,112,28,22,43,291,33,1*74
$GBGSV,3,1,10,02,02,106,,05,16,129,,07,22,060,,09,10,070,,*45
$GBGSV,3,2,10,10,24,087,,11,04,354,,12,18,308,,19,80,113,,*4B
$GBGSV,3,3,10,20,26,112,,22,43,291,,*4F
$GNGLL,5229.62499,N,01326.86332,E,161014.00,A,D*77
$GNRMC,161015.00,A,5229.62499,N,01326.86332,E,0.012,,140920,,,F,V*1A
$GNVTG,,T,,M,0.012,N,0.023,K,D*3A
$GNGGA,161015.00,5229.62499,N,01326.86332,E,5,12,0.66,32.5,M,42.1,M,10.0,4095*65
 
Instead of
$GNGGA,161015.00,5229.62499,N,01326.86332,E,5,12,0.66,32.5,M,42.1,M,10.0,4095*65
 

2 Answers
Best Answer
Suchit Sharma answered 4 weeks ago

Thanks @clive1.
What worked was : to disable each message that starts with F0-00 at UART2 in Ucenter Configuration View -> MSG(messages) -> F0-00 NMEAXXXX  except the GGA message.

clive1 answered 1 month ago

>I have tried to filter the messages in Ucenter Configuration View -> MSG(messages) -> F0-00 NMEA GxGGA on UART2 and USB, I have updated the firmware too , but the problem persists. 

Disable the other NMEA messages on UART2, and save the configuration.