No RTK, and RCTM3 data from the base station.

Q&A forumCategory: QuestionsNo RTK, and RCTM3 data from the base station.
facundo asked 2 years ago

Hi, I’m Facundo from Chile, sorry for my English.
I have 2 ArduSimple boards with an Xbee modules, one for base and other for Rover, all is purchased and configured from ArduSimple.
I read all of questions and try everything but I have the same problem.
I have a good signal and open sky, in 2 minutes I have 2.5 mt of precision (also I changed to 5 minutes, and 1 mt,), the survey is finish and get 3D fix, but if I check the messages from uart2 there is nothing, on both boards, the Xbee are blinking, on the Base GPS>>XBEE and on the Rover XBEE>>GPS, but the Rover don’t revive any signal correction, the rover get very good signal and error of 0,8 mt or less, but standalone.
I read there a minimal Satellite signals to get GNSS Fix, may be in my Country there are a different reception, I get in one try 4 Beidou, 8 Galileo, 8 GPS, 8 Glonass, and the UBX-CFG are min 10 Galileo (I tried to change this to 8, but I can’t ) Also I disable Galileo, but I have the same problem
Please help me 

2 Answers
clive1 answered 2 years ago

You shouldn’t need to fiddle with GNSS constellations.
Enable UBX-NAV-PVT, make sure the BASE is in TIME mode.
Check UBX-CFG-MSG for the RTCM3 messages being enabled and outputting on UART2

facundo answered 2 years ago

Yes, all this is OK, the PVT Position Fix Type : TIME
and the UBX-CFG-MSG RCTM3 are configured to UART2
 

clive1 replied 2 years ago

Seeing RTCM3 messages at ROVER via UBX-RXM-RTCM ?
If not you’re going to focus on the RADIO settings.

facundo replied 2 years ago

I Checked UBX-RXM-RTCM on the rover and all is empty.

facundo replied 2 years ago

On UBX-MON-MSGPP are a lot of packets UNKNOW on UART2, but 0 Packets on RTCM3

clive1 replied 2 years ago

Check appropriate BAUD rate settings for UART2 on both ends.

facundo replied 2 years ago

Thanks for the help, I checked the Xbee Radios, and all are ok, I Checked the baud rates, and on the Rover was set to 38400, I changed to 115200 and works