Bluetooth and PointPerfect not communicating

Q&A forumCategory: QuestionsBluetooth and PointPerfect not communicating
spamalot2021 asked 4 months ago
To use PointPerfect I had to update the firmware. Then I had to update the configuration file. I hoped I could use Bluetooth, PointPerfect didn’t work. I then enabled CFG-UART1INPROT-SPARTN and I could get corrections via the usb hookup to the phone. Via usb, it worked. Then I tried Bluetooth enabling CFG-UART2INPROT-SPARTN. I get coordinates that are the same as uncorrected. What should I do to get PointPerfect corrections with Bluetooth?

1 Answers
Ardusimple Staff answered 4 months ago
It should also work over bluetooth, if you are using ArduSimple Bluetooth at the moment of speaking, note that UART2 interface should be configured at 38’400bps.
replied 4 months ago

I have the Calibrated Surveyor. I loaded the “Bluetooth on simpleRTK2B or simpleRTK2Blite” configuration file. I enabled CFG_MSGOUT_NMEA_ID_GST_UART1  and CFG_MSGOUT_NMEA_ID_GST_UART2 and cfg-uart1inprot-spartn as well as cfg-uart2inprot-spartn.

In u-center it shows CFG_UART2-BAUDRATE and CFG_UART1-BAUDRATE as U4 38,400  0x9600

USB Connection and accuracy is fine. Bluetooth shows paired. I am seeing coordinates with Bluetooth, however no corrections are taking place. The measurements are exactly as I see without PointPerfect corrections connected.

I gather there is no option to adjust baud rate in GNSS Master.

Staff replied 4 months ago

Thank you for the extra information. With calibrated surveyor the only steps are:
– Upload the “bluetooth” configuration file
– Enable SPARTN with cfg-uart2inprot-spartn.

Are you storing in flash memory the changes?
Maybe a few screenshots or video recording on how you are performing the process can help us detect which small step we are missing. You can send them to

replied 4 months ago

I have emailed more information. It was set in Flash and sent via ubx/cfg/cfg.  What is mentioned above didn’t work for me. Using USB I get "N/A" for accuracy and error.

With only cfg-uart2inprot-spartn enabled Bluetooth still does not send corrections.

Wouldn't NMEA messages also have to be enabled on uart1 and uart2? A month and a half and so many hours and still no solution. Please help.

Staff replied 4 months ago

We couldn’t find your email in the info@ardusimple inbox, did you get a reply and case is solved?

Want to learn more about GPS/RTK?

1. Our engineering team will contact you to solve any questions
2. We will keep you updated about promotions and new product releases
3.You will only hear from us when we have important news, we won’t spam your email